HELP please

Engines and Engine Systems
User avatar
Pieter B
Senior Member
Senior Member
Posts: 195
Joined: 29 Sep 2014 12:40
Full Name: Pieter Botha
Nickname: Pieter
Home Town: Alberton
Current 4x4: '02 Nissan Hardbody 3.3
Home Language: Afrikaans
Been thanked: 10 times

Re: HELP please

Post by Pieter B » 15 Feb 2016 13:12

Surely 20W50 oil is too thick for turbocharger use. I'm sure it should rather be a 15W40?

User avatar
ricster
Patrolman 1000+
Patrolman 1000+
Posts: 5440
Joined: 13 Jan 2010 11:16
Full Name: Cedric Warner
Nickname: Cedric
Home Town: Alberton Gauteng
Current 4x4: '99 Nissan Patrol 4.2 Turbo Diesel
Home Language: English
Location: LA..... No not Los Angles ..... Lower Alberton, Gauteng
Has thanked: 170 times
Been thanked: 204 times

Re: HELP please

Post by ricster » 15 Feb 2016 13:18

Ahhh... Frans for presisdeeeeeeeeeent !!!!.... thanks for the feedback.
Regards
Cedric
Nissan Patrol GL 4.2 Diesel Turbo (Iron Maiden)
Nissan SANI 3.0 V6 4x4 (SOLD)
Isuzu KB 280 DT 2x4 ('ol Smokey) - SOLD
Suzuki TL 1000R "V twin" (Growler) - SOLD

Wilkie
Patrolman 1000+
Patrolman 1000+
Posts: 1305
Joined: 24 Feb 2014 15:33
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans
Has thanked: 57 times
Been thanked: 78 times

Re: HELP please

Post by Wilkie » 15 Feb 2016 14:20

Barry on that invoice 'recon engine' doesn't mean much....can of engine heat paint ...R54.00 I can make your engine look like its reconditioned
Did he put new sleeve kits in (piston rings gudgin pin and sleeves)
Did he hone the block and put new rings in
Did he rebore
was the main bearings and big ends replaced
was the oil pump replaced
was the timing chain and guides replace
was the welsh plugs replaced
was the cylinderhead reconditioned (valve seats valve guides)
waterpump etc etc etc
The list goes on and I think that oakkie must give you a proper breakdown of what was done...
You as owner of that vehicle needs peace of mind that you can go on the next River trip or Swazi trip hassle free :mytwocents: :woo: :mytwocents:

Wilkie
Patrolman 1000+
Patrolman 1000+
Posts: 1305
Joined: 24 Feb 2014 15:33
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans
Has thanked: 57 times
Been thanked: 78 times

Re: HELP please

Post by Wilkie » 18 Feb 2016 07:34

Barry any good news on your patrol :think:

gupster
Senior Member
Senior Member
Posts: 142
Joined: 12 Jan 2014 07:25
Full Name: Barry Guppy
Nickname: Baz
Home Town: Hibberdene
Current 4x4: 2001 Nissan Patrol 3.0 GRX
2005 Nissan Patrol 3.0 GR
Home Language: English
Has thanked: 108 times
Been thanked: 18 times

Re: HELP please

Post by gupster » 18 Feb 2016 07:53

Hi Errol. I am just about to take it into Durban to Merc King, a very capable garage. They say they can read the signals live coming from the sensors. I know the owner and so am happy I wont be paying any school fees. I will tell him all the suggestions kindly made on this forum so he has as much info as possible.
By the way, the dip stick was below the min mark but only took 1.5 L to get it up to the max.
I also learnt that turbos dont have seals as we know them but rings or pistons. I found that interesting too.
Regards.
Barry.
PS, hold thumbs for me that the Troll manages 100K
Have Troll, will travel.

Wilkie
Patrolman 1000+
Patrolman 1000+
Posts: 1305
Joined: 24 Feb 2014 15:33
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans
Has thanked: 57 times
Been thanked: 78 times

Re: HELP please

Post by Wilkie » 18 Feb 2016 08:47

hope its a quick fix :salute: :salute:

gupster
Senior Member
Senior Member
Posts: 142
Joined: 12 Jan 2014 07:25
Full Name: Barry Guppy
Nickname: Baz
Home Town: Hibberdene
Current 4x4: 2001 Nissan Patrol 3.0 GRX
2005 Nissan Patrol 3.0 GR
Home Language: English
Has thanked: 108 times
Been thanked: 18 times

Re: HELP please

Post by gupster » 28 Feb 2016 07:54

I got back from Johannesburg last Thursday, after retrieving my Volvo and getting a new turbo from Alert, to find that the idle hunting problem had been resolved. It turned out to be the altitude compensator. Apparently an added 1.5 K resistor sorted the problem out. I dont know how happy I am with the modification as what will happen when I go to Johannesburg or the 3200 plus meter mountains in Ethiopia the engine might be too lean. There were no fault codes thrown up at any time as I checked that first as did the mechanic when he got the Troll.
Does anybody know where the altitude compensator sits as I still have my old Patrol and could scavenge that one. I should have asked the mechanic while I was there.
The turbo was diagnosed as being faulty too at Turbo exchange in Durban. They showed me that there was no gasket where the exhaust smoke came out of during the hunting as the the two surfaces were a conical fit and precisely machined. After investigating all my options, ie replacing the core a much cheaper option, I decided to bite the bullet and buy new. Garrett will not supply a core so it would have to have been someone elses core. Chinese?
When I went to pick up the Mad Man EGT from Brian, he showed me reconned Garrett turbos he gets from the UK, but it has to be on exchange and takes some time. He recommended Alert for a good price on a new Garrett.
As to the oil usage, well I have left the car with the garage to install the EGT gauge as well as the new Turbo so will only find that out when I get the car back. They did say that the engine oil was very black when they changed it and seem to think it might have indicated that the engine was running rich. Its only been 6000 Ks since the complete engine overhaul. I also asked them to examine the diesel filter after they changed it to see if there was any noticeable water or bits. It was clean.
I look forward to your comments and advice.
Regards
Have Troll, will travel.

Wilkie
Patrolman 1000+
Patrolman 1000+
Posts: 1305
Joined: 24 Feb 2014 15:33
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans
Has thanked: 57 times
Been thanked: 78 times

Re: HELP please

Post by Wilkie » 01 Mar 2016 15:27

Hi Baz
hope you came right with your Patrollie
just a bit of info which I experienced as well as also reading about it on the forum..check that the vacuum pipes between the inlet manifold and turbo is correctly installed
which can cause excessive black smoke and lack of power :mytwocents: :mytwocents:

User avatar
ricster
Patrolman 1000+
Patrolman 1000+
Posts: 5440
Joined: 13 Jan 2010 11:16
Full Name: Cedric Warner
Nickname: Cedric
Home Town: Alberton Gauteng
Current 4x4: '99 Nissan Patrol 4.2 Turbo Diesel
Home Language: English
Location: LA..... No not Los Angles ..... Lower Alberton, Gauteng
Has thanked: 170 times
Been thanked: 204 times

Re: HELP please

Post by ricster » 01 Mar 2016 15:49

hey jaaaaa !!... good thinking there Wilkie !!!!.... You may just be onto something there !!!!
Regards
Cedric
Nissan Patrol GL 4.2 Diesel Turbo (Iron Maiden)
Nissan SANI 3.0 V6 4x4 (SOLD)
Isuzu KB 280 DT 2x4 ('ol Smokey) - SOLD
Suzuki TL 1000R "V twin" (Growler) - SOLD

User avatar
PaulvdMerwe
Senior Member
Senior Member
Posts: 124
Joined: 06 Jan 2016 15:21
Full Name: Paul van der Merwe
Nickname: Paul
Home Town: Graaff Reinet
Current 4x4: 2001 Patrol 3.0 DI GRX
Home Language: Afrikaans
Location: Graaff Reinet
Has thanked: 2 times
Been thanked: 6 times

Re: HELP please

Post by PaulvdMerwe » 01 Mar 2016 16:43

Wilkie,

You are on to something,
I just completed an engine overhaul on my ZD30. It was pulling fine on the top end (140 no problem) but to get there, and on the uphills ...... BAD!!!
I also noted lost of black smoke when climbing up hill. Some one suggested that I should check the boost, and that is when I realized I do not hear my turbo spool up. Checked the vacuum lines and found one being incorrect. Sorted that out and now this ZD30 is alive!!!

Post Reply

Return to “09. Engines”

Who is online

Users browsing this forum: No registered users and 0 guests