4.5 Running rough?

Engines and Engine Systems
User avatar
David M
Patrolman
Patrolman
Posts: 842
Joined: 12 Nov 2013 15:13
Full Name: David Marais
Nickname: David Marais
Home Town: Midrand
Current 4x4: 1998 4.5 GL Patrol
2006 4.2 Td Bakkie (SWAMBO's) - The "Firetruck"
Home Language: English
Location: Midrand
Has thanked: 18 times
Been thanked: 84 times

4.5 Running rough?

Post by David M » 03 Nov 2017 15:25

For a couple of years now my 4.5 has been running rougher and rougher and suffering from some bouts of pinging.

Have done all the tried and tested stuff like removing chip, replacing PCV valve, etc etc etc. These things have been discussed in depth before.

Took it to Graham the other day and after swopping MAS sensor and distributor among other things discovered this;
IM under resonator.jpg
IM under resonator.jpg (3.73 MiB) Viewed 1096 times
Would seem that over the years the heat from aftermarket branch manifolds has slowly caused the underside of the resonator box between the air filter and intake manifold to melt allowing air in after the MAS sensor.
IM original.jpg
IM original.jpg (3.01 MiB) Viewed 1096 times
Borrowed one from Graham for the meantime but I can see no reason for the box so here is what I believe to be the solution;

1. Cut the box off of the intake pipe
IM cut.jpg
IM cut.jpg (2.85 MiB) Viewed 1096 times
2. Seal the hole
IM plugged.jpg
IM plugged.jpg (2.36 MiB) Viewed 1096 times
3. Add additional heat deflection
IM heat deflect.jpg
IM heat deflect.jpg (2.09 MiB) Viewed 1096 times
Will fit this weekend and see how it goes.

Moral of the story - If you fit or have aftermarket branch manifolds, ceramic coated or not modify and retain the heat deflection over the manifold.
There are still places out there!!!! - Daniel Goz - The "Tapam" movie

User avatar
Bre
Senior Member
Senior Member
Posts: 202
Joined: 08 Mar 2017 11:27
Full Name: Brent Harris
Nickname: Bre
Home Town: Bellville
Current 4x4: 1999 Nissan Patrol 4.5 GRX
2003 Nissan Hardbody 3.3 SEL DC 4x4
Home Language: English
Has thanked: 36 times
Been thanked: 23 times

Re: 4.5 Running rough?

Post by Bre » 03 Nov 2017 16:23

I've also wondered what the purpose of that box is

User avatar
Alex Roux
Patrolman 1000+
Patrolman 1000+
Posts: 2626
Joined: 11 Jul 2011 10:54
Full Name: Alexander Roux
Nickname: Witblits
Home Town: Johannesburg
Current 4x4: 2004 GU 3TDi (Lexus) - aka "Witblits"
1996: GQ TB48 conversion - aka "Skilpad"
1993: GQ SWB TB42 - aka "Shortie"
Home Language: Afrikaans
Has thanked: 41 times
Been thanked: 135 times

Re: 4.5 Running rough?

Post by Alex Roux » 03 Nov 2017 17:00

David M wrote:Would seem that over the years the heat from aftermarket branch manifolds has slowly caused the underside of the resonator box between the air filter and intake manifold to melt allowing air in after the MAS sensor.
So David, does this mean you have been sucking dirty air? and for how long?
Skilpad & Shortie

User avatar
David M
Patrolman
Patrolman
Posts: 842
Joined: 12 Nov 2013 15:13
Full Name: David Marais
Nickname: David Marais
Home Town: Midrand
Current 4x4: 1998 4.5 GL Patrol
2006 4.2 Td Bakkie (SWAMBO's) - The "Firetruck"
Home Language: English
Location: Midrand
Has thanked: 18 times
Been thanked: 84 times

Re: 4.5 Running rough?

Post by David M » 04 Nov 2017 06:55

Alex Roux wrote:
David M wrote:Would seem that over the years the heat from aftermarket branch manifolds has slowly caused the underside of the resonator box between the air filter and intake manifold to melt allowing air in after the MAS sensor.
So David, does this mean you have been sucking dirty air? and for how long?
Yep and no idea for how long but I think it goes back years.
There are still places out there!!!! - Daniel Goz - The "Tapam" movie

User avatar
Alex Roux
Patrolman 1000+
Patrolman 1000+
Posts: 2626
Joined: 11 Jul 2011 10:54
Full Name: Alexander Roux
Nickname: Witblits
Home Town: Johannesburg
Current 4x4: 2004 GU 3TDi (Lexus) - aka "Witblits"
1996: GQ TB48 conversion - aka "Skilpad"
1993: GQ SWB TB42 - aka "Shortie"
Home Language: Afrikaans
Has thanked: 41 times
Been thanked: 135 times

Re: 4.5 Running rough?

Post by Alex Roux » 04 Nov 2017 07:21

Maybe do an engine flush and change oil thereafter
Skilpad & Shortie

User avatar
David M
Patrolman
Patrolman
Posts: 842
Joined: 12 Nov 2013 15:13
Full Name: David Marais
Nickname: David Marais
Home Town: Midrand
Current 4x4: 1998 4.5 GL Patrol
2006 4.2 Td Bakkie (SWAMBO's) - The "Firetruck"
Home Language: English
Location: Midrand
Has thanked: 18 times
Been thanked: 84 times

Re: 4.5 Running rough?

Post by David M » 04 Nov 2017 08:10

Alex Roux wrote:Maybe do an engine flush and change oil thereafter
I think for once I got lucky. Intake manifold is clean and oil still clear after 4 000 km. Using Delo 400 in it which should clean anything bad out. On previous oil changes my oil has not been black after 10 000 km.

When we replaced the head gasket last year the pistons still looked as if they where sitting in the box, not a mark on the bore and 1 spot of carbon on 1 valve.
There are still places out there!!!! - Daniel Goz - The "Tapam" movie

SJC
Patrolman 1000+
Patrolman 1000+
Posts: 2771
Joined: 23 Nov 2014 14:20
Full Name: Fanus
Nickname: Fanus
Home Town: .
Current 4x4: 2000 Nissan Patrol 4500GRX
Home Language: Afrikaans/English
Has thanked: 87 times
Been thanked: 117 times

Re: 4.5 Running rough?

Post by SJC » 05 Dec 2017 13:04

I took my 4.5 to Graham to have a look at it back when I bought it, he still warned me about this...

David what did you use to block the pipe of (where the box was cut off).?


Was busy today changing oil and inspecting condition of air filter..... also discovered a hole.
photo 2.JPG
photo 2.JPG (398.41 KiB) Viewed 905 times


Quite a bit of dirt alsready got past air filter..
photo 1.JPG
photo 1.JPG (216.35 KiB) Viewed 905 times

B.t.w does GUD make an air filter for a 4.5?

User avatar
David M
Patrolman
Patrolman
Posts: 842
Joined: 12 Nov 2013 15:13
Full Name: David Marais
Nickname: David Marais
Home Town: Midrand
Current 4x4: 1998 4.5 GL Patrol
2006 4.2 Td Bakkie (SWAMBO's) - The "Firetruck"
Home Language: English
Location: Midrand
Has thanked: 18 times
Been thanked: 84 times

Re: 4.5 Running rough?

Post by David M » 05 Dec 2017 14:56

To block the pipe I just went to the local hardware with pipe in hand and tried different things until I found a plastic cap that fitted with minimum modification and siliconed it in.
There are still places out there!!!! - Daniel Goz - The "Tapam" movie

SJC
Patrolman 1000+
Patrolman 1000+
Posts: 2771
Joined: 23 Nov 2014 14:20
Full Name: Fanus
Nickname: Fanus
Home Town: .
Current 4x4: 2000 Nissan Patrol 4500GRX
Home Language: Afrikaans/English
Has thanked: 87 times
Been thanked: 117 times

Re: 4.5 Running rough?

Post by SJC » 06 Dec 2017 20:29

Could not find a suitable "plumbing cap" but found a grease cap that I made to fit. Was slightly larger than the inner diameter of the pipe.
Attachments
photo 2.JPG
photo 1.JPG
Last edited by SJC on 06 Dec 2017 22:17, edited 1 time in total.

User avatar
hugejp
Patrolman 1000+
Patrolman 1000+
Posts: 1542
Joined: 21 Oct 2014 21:01
Full Name: JP Viviers
Nickname: Oupoot
Home Town: JHB
Current 4x4: PATROL COLLECTION
2004 4.8 GRX "Tinkerbell"
2003 4.2 tdi GRX "The Coal Roller"
Home Language: Half & Half
Has thanked: 107 times
Been thanked: 86 times

Re: 4.5 Running rough?

Post by hugejp » 06 Dec 2017 21:41

Mooi Fanus!
----------------------------------------------------------------------

You CAN with a NISSAN!

Jy KAN met 'n DATSUN!

Post Reply

Return to “09. Engines”

Who is online

Users browsing this forum: No registered users and 0 guests