Odometer Overclocking / Cluster Failure

Post Reply
Mowgli
Newbie
Newbie
Posts: 1
Joined: 30 May 2017 10:03
Full Name: ADITYA
Nickname: MOWGLI
Home Town: Nairobi
Current 4x4: Nissan Patrol 2004 TB4.5 Petrol
Home Language: English

Odometer Overclocking / Cluster Failure

Post by Mowgli » 30 May 2017 14:36

Hi all, hope the week is going well. Got a small issue with my odometer, basically it is overclocking, showing around 4-6kms travelled for every actual 1km. All other instruments, fuel, temperature, speedometer working well. I am told that the cluster need to be replaced for around USD 2000 but have also checked online and note this is quite a common problem for Patrols. Anyone who has also experienced this and any luck with correcting it without having to replace the whole cluster? Thank you! Mowgli

User avatar
Tinus lotz
Moderator
Posts: 6564
Joined: 29 Aug 2010 13:07
Full Name: Tinus lotz
Nickname: Tinus lotz
Home Town: Centurion
Current 4x4: Nissan patrol 4.8 GRX 2005

Toyota 2.7 legend 35 LWB 4X4
Home Language: Afrikaans
Has thanked: 496 times
Been thanked: 236 times

Re: Odometer Overclocking / Cluster Failure

Post by Tinus lotz » 30 May 2017 17:38

Hey welcome here order one from dawid volskenk he has some avalible iam sure :thumbup:

Picasso
Senior Member
Senior Member
Posts: 256
Joined: 27 Jul 2014 15:56
Full Name: HS
Nickname: Picasso
Home Town: Pretoria
Current 4x4: Nissan Patrol
T3 Syncro
Home Language: German
Has thanked: 9 times
Been thanked: 32 times

Re: Odometer Overclocking / Cluster Failure

Post by Picasso » 30 May 2017 17:54

David Voschenk
083 499 1588
0027 83 499 1588

User avatar
Herrie
Moderator
Posts: 3655
Joined: 08 Apr 2009 07:17
Full Name: Kobus Pienaar
Nickname: Herrie
Home Town: Kempton Park
Current 4x4: 1999 Patrol 4500e GRX
1983 Datsun Safari
Home Language: Afrikaans
Location: Kempton Park
Has thanked: 70 times
Been thanked: 82 times

Re: Odometer Overclocking / Cluster Failure

Post by Herrie » 30 May 2017 18:06

Welcome here to us! :thumbup:
Herrie op Safari/Patrollie
1983 Safari
1999 Patrol 4500 GRX

User avatar
SJC
Patrolman 1000+
Patrolman 1000+
Posts: 2517
Joined: 23 Nov 2014 14:20
Full Name: SJC
Nickname: Fanus
Home Town: Lowveld
Current 4x4: 4.2TD Pickup & 4500 GRX
Home Language: Afrikaans/English
Has thanked: 75 times
Been thanked: 103 times

Re: Odometer Overclocking / Cluster Failure

Post by SJC » 30 May 2017 18:18

Tinus lotz wrote:Hey welcome here order one from dawid volskenk he has some avalible iam sure :thumbup:
Picasso wrote:David Voschenk
083 499 1588
0027 83 499 1588
Will he be able to "ship" it to Nairobi?

Picasso
Senior Member
Senior Member
Posts: 256
Joined: 27 Jul 2014 15:56
Full Name: HS
Nickname: Picasso
Home Town: Pretoria
Current 4x4: Nissan Patrol
T3 Syncro
Home Language: German
Has thanked: 9 times
Been thanked: 32 times

Re: Odometer Overclocking / Cluster Failure

Post by Picasso » 30 May 2017 18:37

DHL.... around 1000 - 1500 R freight

User avatar
iandvl
Patrolman 1000+
Patrolman 1000+
Posts: 1046
Joined: 12 Jan 2015 13:26
Full Name: Ian de Villiers
Nickname: Ian
Home Town: Brits
Current 4x4: Nissan Patrol 4.5 GRX
Nissan Hardbody 2.4 4x4
Home Language: English
Has thanked: 114 times
Been thanked: 119 times

Re: Odometer Overclocking / Cluster Failure

Post by iandvl » 31 May 2017 11:25

Mowgli wrote:Hi all, hope the week is going well. Got a small issue with my odometer, basically it is overclocking, showing around 4-6kms travelled for every actual 1km. All other instruments, fuel, temperature, speedometer working well. I am told that the cluster need to be replaced for around USD 2000 but have also checked online and note this is quite a common problem for Patrols. Anyone who has also experienced this and any luck with correcting it without having to replace the whole cluster? Thank you! Mowgli
I've read up quite a bit on this. Whilst Odometer failure seems to be quite common with Patrols with mechanical odometers, I've not found anything indicating failures with the electronic odometers. Your model Patrol presumably has a digital odometer. As such, I would assume the issue is going to be electrical.

Looking at the manual, there are a few things which could be the issue. Most significantly, you mention that the speedometer works correctly. Does it work accurately though ? If it is showing considerably higher speeds than you are travelling, I would suspect the "speed sensor", which is located in the transmission. This is relatively easy to test.

If the speedometer works correctly and accurately, I would imagine that it could be the flexible connector between the meter control unit and the speedometer unit, or the speedometer itself.

There is a diagnostic test you can perform on the cluster, as well as several measurements you can make to verify what the actual issue is. Please send me a PM, and I will forward you the relevant sections of the manual.

In short: it is highly unlikely you need to replace the entire cluster. Worst case: it will be a single component or two. Best case: it is just the flexible connector that is not connected properly.

Please keep us up to date.

Post Reply

Return to “13. Electrical & Electronics”

Who is online

Users browsing this forum: No registered users and 0 guests