Patrol Pics



HELP please

Engines and Engine Systems

Re: HELP please

Postby JoshJ » 11 Feb 2016 22:14

Interesting, please keep the findings and feedback comming......
Being alive is a Blessing!!

Regards,
Joshua
User avatar
JoshJ
Patrolman 1000+
Patrolman 1000+
 
Posts: 1029
Joined: 30 Nov 2013 16:16
Has thanked: 76 times
Been thanked: 80 times
Full Name: Joshua Joubert
Nickname: Joshua
Home Town: Swakopmund Namibia
Current 4x4: 2003 Patrol 4.8 GRX
Home Language: Afrikaans

Re: HELP please

Postby Wilkie » 12 Feb 2016 07:17

Barry ,does this only happen when you selects a gear or when you press the clutch.....has your patrol got a anti stall function :think: :think:
Wilkie
Patrolman 1000+
Patrolman 1000+
 
Posts: 1243
Joined: 24 Feb 2014 15:33
Has thanked: 48 times
Been thanked: 75 times
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans

Re: HELP please

Postby Wilkie » 12 Feb 2016 07:32

A buddy of mine had a similar problem with the white smoke and erratic idling don't know if it was with vehicle in gear or not
had to replace the Turbo Boost control valve R4700 installed :thumbup:
Wilkie
Patrolman 1000+
Patrolman 1000+
 
Posts: 1243
Joined: 24 Feb 2014 15:33
Has thanked: 48 times
Been thanked: 75 times
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans

Re: HELP please

Postby gupster » 12 Feb 2016 07:46

Hi Errol. It only happens when I engage a gear, any gear for that matter even reverse. I can pump the clutch for ages with no change in engine idle speed. I dont know if it has an anti stall device but if that was faulty it could be my problem. Maybe someone on the forum will know. I have also established now that it only happens when hot. I checked the pipes from the turbo control thingy and it and the pipes look good but that does not mean its working properly. I still have my old 2001 3.0 so can always start swapping things but its in Durban at the moment and I am in Hibberdene.
Regards.

Barry
Have Troll, will travel.
gupster
Senior Member
Senior Member
 
Posts: 139
Joined: 12 Jan 2014 07:25
Has thanked: 107 times
Been thanked: 18 times
Full Name: Barry Guppy
Nickname: Baz
Home Town: Hibberdene
Current 4x4: 2001 Nissan Patrol 3.0 GRX
2005 Nissan Patrol 3.0 GR
Home Language: English

Re: HELP please

Postby ricster » 12 Feb 2016 08:42

Wishing now I had followed Cedrics advice and gone for a truck without a brain...... My friend fear not cause deep down I also wouldn't mind a 3.0 Patrol for its fuel economy !!!! Don't stress, you will get that sweet ride running perfectly and you will kick me in the goolies saying .... see Cedric, these machines are not as bad as everyone thinks !!!! :lol: :lol: :lol:

Good luck.... Maybe give Frans a call for his opinion...worth a shot !!
Regards
Cedric
Nissan Patrol GL 4.2 Diesel Turbo (Iron Maiden)
Nissan SANI 3.0 V6 4x4 (SOLD)
Isuzu KB 280 DT 2x4 ('ol Smokey) - SOLD
Suzuki TL 1000R "V twin" (Growler) - SOLD
User avatar
ricster
Patrolman 1000+
Patrolman 1000+
 
Posts: 5243
Joined: 13 Jan 2010 11:16
Location: LA..... No not Los Angles ..... Lower Alberton, Gauteng
Has thanked: 154 times
Been thanked: 182 times
Full Name: Cedric Warner
Nickname: Cedric
Home Town: Alberton Gauteng
Current 4x4: '99 Nissan Patrol 4.2 Turbo Diesel
Home Language: English

Re: HELP please

Postby juice » 12 Feb 2016 09:24

Hi Barry
Had a similar issue , arrive home after the river trip , car would idle but as I put it into gear the motor would idle erratic, overboost limp
black smoke , white smoke , computer blamed the diesel pump, overhauled (mega bucks ) problem not solved
changed the boost control valve , overboost sensor ,still nothing , last thing I should have changed first , the MAF problem solved
my baby is running like the day a bought it passing fellow patrol petrol head filling up, yes the zd30 has a bit to much electronic
The MAF controls the ecu ,with the rest of the sensor brigade crank sensor, accelarotar pot , ejection timing , boost control vale , overboost sensor and the rest there is also a sensor on the gearbox to switch warmup(heat) switch off when you put it into gear, so go check them and all making that are all click in
regards
juice
juice
Senior Member
Senior Member
 
Posts: 152
Joined: 30 Jul 2010 16:40
Has thanked: 0 time
Been thanked: 8 times
Full Name: greg justus
Nickname: juice
Home Town: benoni
Current 4x4: patrol 2001
safari 1984 wagon
safari 1982 wagon
Home Language: english

Re: HELP please

Postby gupster » 12 Feb 2016 09:30

Thanks Cedric for that encouragement. I have a friend coming down from Jhb tomorrow so frantically trying to get my Plet home in order and so no time to try out all the advice given to me. She will have her car so the Troll will just have to wait for a few days. And yes, I will give Frans a call as I have heard him mentioned often on this forum as being a guru with our cars. I will definitely post the solution, sale he he, when I find out.
Thanks to all.
Regards.Barry
Have Troll, will travel.
gupster
Senior Member
Senior Member
 
Posts: 139
Joined: 12 Jan 2014 07:25
Has thanked: 107 times
Been thanked: 18 times
Full Name: Barry Guppy
Nickname: Baz
Home Town: Hibberdene
Current 4x4: 2001 Nissan Patrol 3.0 GRX
2005 Nissan Patrol 3.0 GR
Home Language: English

Re: HELP please

Postby ricster » 12 Feb 2016 10:39

No stress bud ...But Juices advice might just be hitting the spot... maybe a good clean of the MAF with a can of Electro clean ( DONE CAREFULLY )and see if it is better.
Regards
Cedric
Nissan Patrol GL 4.2 Diesel Turbo (Iron Maiden)
Nissan SANI 3.0 V6 4x4 (SOLD)
Isuzu KB 280 DT 2x4 ('ol Smokey) - SOLD
Suzuki TL 1000R "V twin" (Growler) - SOLD
User avatar
ricster
Patrolman 1000+
Patrolman 1000+
 
Posts: 5243
Joined: 13 Jan 2010 11:16
Location: LA..... No not Los Angles ..... Lower Alberton, Gauteng
Has thanked: 154 times
Been thanked: 182 times
Full Name: Cedric Warner
Nickname: Cedric
Home Town: Alberton Gauteng
Current 4x4: '99 Nissan Patrol 4.2 Turbo Diesel
Home Language: English

Re: HELP please

Postby Wilkie » 12 Feb 2016 10:47

ricster wrote:No stress bud ...But Juices advice might just be hitting the spot... maybe a good clean of the MAF with a can of Electro clean ( DONE CAREFULLY )and see if it is better.



I SECOND THAT
Goodluck
Wilkie
Patrolman 1000+
Patrolman 1000+
 
Posts: 1243
Joined: 24 Feb 2014 15:33
Has thanked: 48 times
Been thanked: 75 times
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
Rebuilding Nissan safari ldv
2004 BMW 3.0D X5
Home Language: Afrikaans

Re: HELP please

Postby gupster » 12 Feb 2016 18:02

Gee Juice, I have just logged on now and what you have said makes perfect sense. I have a can of cleaner so will do that first thing tomorrow, or maybe second, he he. Today I had to quickly use the truck and confirmed its only when it warms up that the problem occurs. I also noted that I have been unclear with the symptoms by forgetting to mention that if I engage a gear and keep the revs up there is no problem, ie anything above 1000 rpm is fine. So normal driving is fine.

Regards.

Barry
Have Troll, will travel.
gupster
Senior Member
Senior Member
 
Posts: 139
Joined: 12 Jan 2014 07:25
Has thanked: 107 times
Been thanked: 18 times
Full Name: Barry Guppy
Nickname: Baz
Home Town: Hibberdene
Current 4x4: 2001 Nissan Patrol 3.0 GRX
2005 Nissan Patrol 3.0 GR
Home Language: English

PreviousNext

Return to 09. Engines

Who is online

Users browsing this forum: No registered users and 1 guest