DEAD PATROL ENGINE

Engines and Engine Systems
Maurice_Mawson
Junior Member
Junior Member
Posts: 15
Joined: 08 Oct 2012 20:53
Full Name: Maurice Mawson
Nickname: Maurice_Mawson
Home Town: Meyersdal
Current 4x4: Patrol 3.0 Tdi
Home Language: English
Been thanked: 2 times

DEAD PATROL ENGINE

Post by Maurice_Mawson » 18 Apr 2015 09:27

Hi guys,

My 2002 3.0 TDI ZD30 died a few weeks ago. It was just as if I had turned the key off, engine light came on and that was that.

Took it Nissan and they could not do anything with it, so they sent it to the Bosch Diesel Centre who also cannot get it started either.

Bosch claim that they have removed and “calibrated the diesel pump” but still no joy.

Yesterday I looked at the vehicle and tried to start it using the information found on other forums, by connecting pin 6 on the PSG5 plug to ground and pin 7 to +12VDC. Still it does not want to know.

Does anyone know a KNOWLEDGEABLE ZD30 diesel specialist in the Johannesburg area???

Ideally to eliminate my VP44 pump from the equation I need someone to test my pump on running ZD30 engine or to fit a pump that is definitely running a ZD30 motor.

Thanks in advance for any tips, help or assistance (no matter how small)

As you can imagine I am now becoming rather desperate

Maurice Mawson

User avatar
Tinus lotz
Moderator
Posts: 7063
Joined: 29 Aug 2010 13:07
Full Name: Tinus lotz
Nickname: Tinus lotz
Home Town: Centurion
Current 4x4: Nissan patrol 4.8 GRX 2005

Toyota 2.7 legend 35 LWB 4X4
Home Language: Afrikaans
Has thanked: 557 times
Been thanked: 290 times

Re: DEAD PATROL ENGINE

Post by Tinus lotz » 18 Apr 2015 11:00

Pm juice on the forum he is very good with those engines. ....he knows the correct companies that can test your pump ect on the engine ......he also might be able to help with spare pump otherwise pm me your no and i can see what we can do :salute:

Maurice_Mawson
Junior Member
Junior Member
Posts: 15
Joined: 08 Oct 2012 20:53
Full Name: Maurice Mawson
Nickname: Maurice_Mawson
Home Town: Meyersdal
Current 4x4: Patrol 3.0 Tdi
Home Language: English
Been thanked: 2 times

Re: DEAD PATROL ENGINE

Post by Maurice_Mawson » 18 Apr 2015 12:06

Hi Tinus, thanks a lot I have PM'd both you and Juice.


I also want to make sure that once I get my Patrol going again that everyone can benefit from my School fees, That is what these forums are all about, helping each other QQQ


All the best

Maurice

gupster
Senior Member
Senior Member
Posts: 180
Joined: 12 Jan 2014 07:25
Full Name: Barry Guppy
Nickname: Baz
Home Town: Hibberdene
Current 4x4: 2001 Nissan Patrol 3.0 GRX
2005 Nissan Patrol 3.0 GR
Home Language: English
Has thanked: 121 times
Been thanked: 29 times

Re: DEAD PATROL ENGINE

Post by gupster » 18 Apr 2015 16:56

Hi Maurice. Have you or the agents looked to see if there are any faults logged on the ECU? If so, what are they? I remember someone having the crank position sensor on a RR going and having the same results as you.
Regards.

Barry
Have Troll, will travel.

User avatar
Kagiso II
Patrolman 1000+
Patrolman 1000+
Posts: 3662
Joined: 10 Jun 2009 16:58
Full Name: Mac Mc Menamin
Nickname: Oom Mac [Uncle Mac] [Uncle] [Oompie] Kagiso
Home Town: BrentwoodPark, Benoni
Current 4x4: 1982 Datsun Safari 2,8 aka LOBO; [1,300,000 Km verby !]
'99 PATROL 4,2 diesel.
2012 Jimny [SWAMBO se Kantoor-toe]
Home Language: AFRIKAANS
Location: Benoni and wherever the Outreach takes me.
Has thanked: 289 times
Been thanked: 107 times
Contact:

Re: DEAD PATROL ENGINE

Post by Kagiso II » 18 Apr 2015 18:21

Hey Daa' Maurice..

Does the engine still swing over ? My ZD 30 Hard Body did that and in the end it was the battery that did not deliver the amps required .. the Volts would swing the engine BUT not enough oomph the make the diesel start.

Then, when similar *&^%agga with Agaraob [3.0 Di Patrol] .. it ended up the ENGEN garage in Atterbury Rd had water in their diesel [23 % nogal] it also refused.

SAC Centurion fixed it

But in your instance -- I think contact GROOTSEUN [Driko Henningse] at their new workshop .. he is sure to fix that ZD 30 motor [he had the Hard Body and then the Patrol .. so he knows the ZD 3,0] = DC Customs : 0861 911 333

They fixed the Pradothe other day when the whole dash board lit up like Guy Fawkes centenery :-)
Don't bring God down to your level of faith ... bring your faith up to His level!

Maurice_Mawson
Junior Member
Junior Member
Posts: 15
Joined: 08 Oct 2012 20:53
Full Name: Maurice Mawson
Nickname: Maurice_Mawson
Home Town: Meyersdal
Current 4x4: Patrol 3.0 Tdi
Home Language: English
Been thanked: 2 times

Re: DEAD PATROL ENGINE

Post by Maurice_Mawson » 19 Apr 2015 15:13

Hi Barry and Kasigo II,

Many thanks for your responses.

Barry, Nissan did read the codes and when I got the vehicle to them, they said they were related to the injection pump. However since Bosch have had their hands on it apparently they can no longer read any fault codes. I only hope they lined everything up correctly when they re-installed the injection pump.

I am going to Nissan next week to have a look myself and get the real story. I have the gut feeling that all this “smoke and mirrors” talk is going to leave me with a huge bill. Nevertheless I need to get my Patrol back on the road as soon as possible.

Kasgio II, thanks for the tip I did speak to Driko when it first broke down, I am going to see what Nissan have to say before planning my next move.

All the best

Maurice

User avatar
David M
Patrolman
Patrolman
Posts: 843
Joined: 12 Nov 2013 15:13
Full Name: David Marais
Nickname: David Marais
Home Town: Midrand
Current 4x4: 1998 4.5 GL Patrol
2006 4.2 Td Bakkie (SWAMBO's) - The "Firetruck"
Home Language: English
Location: Midrand
Has thanked: 18 times
Been thanked: 84 times

Re: DEAD PATROL ENGINE

Post by David M » 19 Apr 2015 23:05

I had exactly the same thing with a ZD30 Hardbody a couple of years ago.

It had a Unichip that failed. Removed and blanked off the Unichip and all was perfect.

If you bought it 2nd hand there may be a Unichip that you do not even know about.

As Oom Mac says SAC Centurion would know what to do. Unfortunately Nissan would not even have a clue what you are talking about.

Nissan gave me a bill for R 13 000 to refurbish the pump which was not even the problem. Helped them shove that bill up their ar$%.
There are still places out there!!!! - Daniel Goz - The "Tapam" movie

Maurice_Mawson
Junior Member
Junior Member
Posts: 15
Joined: 08 Oct 2012 20:53
Full Name: Maurice Mawson
Nickname: Maurice_Mawson
Home Town: Meyersdal
Current 4x4: Patrol 3.0 Tdi
Home Language: English
Been thanked: 2 times

Re: DEAD PATROL ENGINE

Post by Maurice_Mawson » 20 Apr 2015 08:41

Thanks for the tip.

I did buy it secondhand - Bosch did find a chip on it. They took it out but it still refuses to start. AAARRRGGGHHH

User avatar
ricster
Patrolman 1000+
Patrolman 1000+
Posts: 5938
Joined: 13 Jan 2010 11:16
Full Name: Cedric Warner
Nickname: Cedric
Home Town: Alberton Gauteng
Current 4x4: '99 Nissan Patrol 4.2 Turbo Diesel
Home Language: English
Location: LA..... No not Los Angles ..... Lower Alberton, Gauteng
Has thanked: 244 times
Been thanked: 255 times

Re: DEAD PATROL ENGINE

Post by ricster » 20 Apr 2015 08:52

Hey Maurice,

Nice to see a fellow Albertonian here. Is yours the green one I see every now and again ( Young Stewart and Assoc. Land surveyors )?

Unfortunately I'm not too clued up on the ZD30 motor, only the TD42.

In my limited knowledge of these motors, I'm going to make suggestions, but they may be total rubbish.

If the motor swings over easily, is the fuel getting to the pump? How is the diesel filter? Is there a lift pump that pumps diesel to the injector pump? Is there a banjo filter on those diesel pumps and is it clean. Are the injectors functioning? If one injector is not functioning then I doubt that the motor would start.

Sometimes its the simple things that create the biggest headaches !!

If you need any assistance give me a shout. I'm in Brackenhurst, and work in Randhart opposite the Nando's amd Action cricket
0-eight-two 4 4 five-five 4 4 one
Regards
Cedric
Nissan Patrol GL 4.2 Diesel Turbo (Iron Maiden)
Nissan SANI 3.0 V6 4x4 (SOLD)
Isuzu KB 280 DT 2x4 ('ol Smokey) - SOLD
Suzuki TL 1000R "V twin" (Growler) - SOLD

Maurice_Mawson
Junior Member
Junior Member
Posts: 15
Joined: 08 Oct 2012 20:53
Full Name: Maurice Mawson
Nickname: Maurice_Mawson
Home Town: Meyersdal
Current 4x4: Patrol 3.0 Tdi
Home Language: English
Been thanked: 2 times

Re: DEAD PATROL ENGINE

Post by Maurice_Mawson » 20 Apr 2015 09:04

Hi Cedric, thanks for the reply.


We did meet once at the filling station on Hennie Alberts, mine is the silver grey Patrol with the colour matched snorkel. You actually put me onto this forum


I will be going to Nissan this week to have look for myself and I agree it is the silliest things that complicate our lives.

All the best

Maurice

Post Reply

Return to “09. Engines”

Who is online

Users browsing this forum: No registered users and 0 guests