Sub-Tank light on after battery terminal found loose ?

User avatar
Russ Kellermann
Patrolman 1000+
Patrolman 1000+
Posts: 1122
Joined: 01 Feb 2010 22:39
Full Name: Russell Kellermann
Nickname: Russell Kellermann
Home Town: Cape Town ,but raised in the Tanskei
Current 4x4: 2007 Patrol 4.2D Pickup
Home Language: English
Has thanked: 1 time
Been thanked: 53 times

Sub-Tank light on after battery terminal found loose ?

Post by Russ Kellermann » 16 May 2011 08:07

Hizit lads,

So when i got back to my truck after work yesterday the motor was dead. Opened up to find the Negative terminal loose (it has never been a tight fit) , so i tightened up and everything started just fine.

However, now the sub-tank light remains on permanently :helpsign: , also, if i press the sub tank button the little green light on the button does NOT glow.

What should i look at first ?

Fuse?
Sensor on subtank?
completely disable battery and start again?

Any advise welcomed.

Russ
'07 Patrol Pickup TD42 N/A,285's KM2,3" Lift,ONCA Bars,Warn High Mount,Alu Canopy, and some other Stuff.

User avatar
G-MAN
Patrolman 1000+
Patrolman 1000+
Posts: 1347
Joined: 02 May 2009 19:50
Full Name: A.G.HOLMES
Nickname: G-MAN
Home Town: Cape Town, Noordhoek
Current 4x4: PATROL 4.8 GRX 2008, PATROL 4.8 GRX 2007, PATROL 4.8 GRX 2006, Defender 90 2.8i...
Home Language: Engels
Location: Cape Town, Noordhoek.
Has thanked: 3 times
Been thanked: 9 times

Re: Sub-Tank light on after battery terminal found loose ?

Post by G-MAN » 16 May 2011 08:22

Morning Russ.
Remove and refit fuse before doing anything else. :wink:
Sucks Gas and Hauls Ass!

User avatar
Kagiso II
Patrolman 1000+
Patrolman 1000+
Posts: 3666
Joined: 10 Jun 2009 16:58
Full Name: Mac Mc Menamin
Nickname: Oom Mac [Uncle Mac] [Uncle] [Oompie] Kagiso
Home Town: BrentwoodPark, Benoni
Current 4x4: 1982 Datsun Safari 2,8 aka LOBO; [1,300,000 Km verby !]
'99 PATROL 4,2 diesel.
2012 Jimny [SWAMBO se Kantoor-toe]
Home Language: AFRIKAANS
Location: Benoni and wherever the Outreach takes me.
Has thanked: 291 times
Been thanked: 109 times
Contact:

Re: Sub-Tank light on after battery terminal found loose ?

Post by Kagiso II » 16 May 2011 13:42

same as re-booting the computer... off power [take POSITIVE off first en put back LAST] wait at least 20 seconds before reconnecting [but as the man said - do the fuse thing first .
Don't bring God down to your level of faith ... bring your faith up to His level!

JG Shields
Patrolman
Patrolman
Posts: 927
Joined: 18 Aug 2009 14:52
Full Name: JG Shields
Nickname: JG
Home Town: Pretoria
Current 4x4: Toyota Land Cruiser 105 GX 4500 EFi
Home Language: Afrikaans
Location: Pretoria

Re: Sub-Tank light on after battery terminal found loose ?

Post by JG Shields » 17 May 2011 07:55

Russ, did you not also had battery trouble a short while ago? Reason for my question.....In my 3.0Di the sub-tank light indicated to more than only sub-tank related faults, amongst others alternator/regulator trouble. Refer to the workshop manual for details. It is in there. If I am not mistaken though, the 3.0Di has a more complex management system that the 4.2D.

As G-Man and Oom Mac says, do the fuse thing first. However if the problems remains, chech the applicable relay and have your charging system checked out.
Patrol fan!

User avatar
Russ Kellermann
Patrolman 1000+
Patrolman 1000+
Posts: 1122
Joined: 01 Feb 2010 22:39
Full Name: Russell Kellermann
Nickname: Russell Kellermann
Home Town: Cape Town ,but raised in the Tanskei
Current 4x4: 2007 Patrol 4.2D Pickup
Home Language: English
Has thanked: 1 time
Been thanked: 53 times

Re: Sub-Tank light on after battery terminal found loose ?

Post by Russ Kellermann » 17 May 2011 09:44

Ok the problem is fixed.

Pulled the fuse and reinstalled - didn't work.

So i pulled the negative terminal off, cleaned with paper towel on terminal and connection ring, pulled out fuse. Then refitted them both and problem is gone!

I now believe that the battery problems i had earlier were because of bad terminal connections and/or earthing. However, i am going to take it to GMan to put through the diagnostics test just to be sure.

Sub tank button now works and subtank indicator signal on dash only on during ignition as per always.

Very stoked it wasn;t something serious.

Thanks Boys.
'07 Patrol Pickup TD42 N/A,285's KM2,3" Lift,ONCA Bars,Warn High Mount,Alu Canopy, and some other Stuff.

User avatar
Kagiso II
Patrolman 1000+
Patrolman 1000+
Posts: 3666
Joined: 10 Jun 2009 16:58
Full Name: Mac Mc Menamin
Nickname: Oom Mac [Uncle Mac] [Uncle] [Oompie] Kagiso
Home Town: BrentwoodPark, Benoni
Current 4x4: 1982 Datsun Safari 2,8 aka LOBO; [1,300,000 Km verby !]
'99 PATROL 4,2 diesel.
2012 Jimny [SWAMBO se Kantoor-toe]
Home Language: AFRIKAANS
Location: Benoni and wherever the Outreach takes me.
Has thanked: 291 times
Been thanked: 109 times
Contact:

Re: Sub-Tank light on after battery terminal found loose ?

Post by Kagiso II » 17 May 2011 09:46

Plesier Russ - het jy reggekom met die sleutel saga?
Don't bring God down to your level of faith ... bring your faith up to His level!

User avatar
Russ Kellermann
Patrolman 1000+
Patrolman 1000+
Posts: 1122
Joined: 01 Feb 2010 22:39
Full Name: Russell Kellermann
Nickname: Russell Kellermann
Home Town: Cape Town ,but raised in the Tanskei
Current 4x4: 2007 Patrol 4.2D Pickup
Home Language: English
Has thanked: 1 time
Been thanked: 53 times

Re: Sub-Tank light on after battery terminal found loose ?

Post by Russ Kellermann » 17 May 2011 10:07

Nee,maar ek is nou besig om dit klaar te maak. I don;t really know where to begin though. I'm going to go straight to nissan first and see what the deal is (and cost !!!) , and take it form there.

I've been so bloody busy with work and been shooting all up till sunday evening, so havn;t done a thing yet. PG Glass also only fitting my window as i write this, over a week to get a piece of glass from JHB , might make a mention on Hello Peter. Yho, i was mad.

Will keep you boys posted on progress and how i get it sorted.
'07 Patrol Pickup TD42 N/A,285's KM2,3" Lift,ONCA Bars,Warn High Mount,Alu Canopy, and some other Stuff.

User avatar
Russ Kellermann
Patrolman 1000+
Patrolman 1000+
Posts: 1122
Joined: 01 Feb 2010 22:39
Full Name: Russell Kellermann
Nickname: Russell Kellermann
Home Town: Cape Town ,but raised in the Tanskei
Current 4x4: 2007 Patrol 4.2D Pickup
Home Language: English
Has thanked: 1 time
Been thanked: 53 times

Re: Sub-Tank light on after battery terminal found loose ?

Post by Russ Kellermann » 17 May 2011 12:50

Ok, so Nissan said before i start ordering locks from all over the world to match the key etc i must first make a turn past "Turnkey" (ironically). It was just up the road anyways in Diep river.

What a great business. Friendly, clean, equipped, and knowledgeable. I wasn;t sure what they would say, but they looked at the lock and said it'd be fixed within an hour.

40mins later it was done at a cost of R280.00 - and the lock feels better and turns smoother when it did as a new vehicle. Very chuffed.
'07 Patrol Pickup TD42 N/A,285's KM2,3" Lift,ONCA Bars,Warn High Mount,Alu Canopy, and some other Stuff.

User avatar
Peter Connan
Moderator
Posts: 5421
Joined: 10 Sep 2010 07:21
Full Name: Peter Connan
Nickname: Piet
Home Town: Kempton Park
Current 4x4: 1996 Patrol 4.5SGL
Home Language: Afrikaans
Location: Kempton Park
Has thanked: 285 times
Been thanked: 366 times

Re: Sub-Tank light on after battery terminal found loose ?

Post by Peter Connan » 17 May 2011 13:12

:thumbup:

Glad you got sorted.
Mag ons ons kenniskry met lekkerkry aanhoukry.

User avatar
Herrie
Moderator
Posts: 3772
Joined: 08 Apr 2009 07:17
Full Name: Kobus Pienaar
Nickname: Herrie
Home Town: Kempton Park
Current 4x4: 1999 Patrol 4500e GRX
1983 Datsun Safari
Home Language: Afrikaans
Location: Kempton Park
Has thanked: 70 times
Been thanked: 98 times

Re: Sub-Tank light on after battery terminal found loose ?

Post by Herrie » 17 May 2011 14:32

So Nissan gave you good advise!! :woo:
Herrie op Safari/Patrollie
1983 Safari
1999 Patrol 4500 GRX

Post Reply

Return to “13. Electrical & Electronics”

Who is online

Users browsing this forum: No registered users and 1 guest