ZD30 not starting

Engines and Engine Systems
Post Reply
velzing
Newbie
Newbie
Posts: 3
Joined: 20 Jun 2018 10:33
Full Name: Erik Velzing
Nickname: vellie
Home Town: Windhoek
Current 4x4: Nissan Patrol Y61
Home Language: Spanish
Been thanked: 4 times

ZD30 not starting

Post by velzing » 20 Jun 2018 11:12

Dear all,

When i bought my partol it was like a dream come true: less then 50,000 km. driven and 3 years old.
The first trips were perfect.
A month ago I came back, driving about 100km/h and the car just stopped. No lights on the dashboard, just stopped and no way to get it started again.
I was helped on the road and some mechanics put an inline pump before the fuel filter.
I manged to get home.
Next day to a mechanic...
The car has seen 4 mechanics. Diesel pump is OK.
Nissan said the fuel pump has to be changed, the mechanics say it's OK.
Nobody seems to find the problem.
Fault codes:
1089
0093
0087
0090
0088
0235
Now a mechanic says the injectors most be replaced.
Does anyone have an idea what could be wrong? My love for Nissan and Patrol have vanished over the last weeks. How can I ever rely on a Nissan again?
Please help me out.

Picasso
Senior Member
Senior Member
Posts: 299
Joined: 27 Jul 2014 15:56
Full Name: HS
Nickname: Picasso
Home Town: Pretoria
Current 4x4: Nissan Patrol
T3 Syncro
Home Language: German
Has thanked: 11 times
Been thanked: 40 times

Re: ZD30 not starting

Post by Picasso » 20 Jun 2018 11:41

velzing wrote:
20 Jun 2018 11:12
Dear all,

When i bought my partol it was like a dream come true: less then 50,000 km. driven and 3 years old.
The first trips were perfect.
A month ago I came back, driving about 100km/h and the car just stopped. No lights on the dashboard, just stopped and no way to get it started again.
I was helped on the road and some mechanics put an inline pump before the fuel filter.
I manged to get home.
Next day to a mechanic...
The car has seen 4 mechanics. Diesel pump is OK.
Nissan said the fuel pump has to be changed, the mechanics say it's OK.
Nobody seems to find the problem.
Fault codes:
1089
0093
0087
0090
0088
0235
Now a mechanic says the injectors most be replaced.
Does anyone have an idea what could be wrong? My love for Nissan and Patrol have vanished over the last weeks. How can I ever rely on a Nissan again?
Please help me out.

Good day Erik
and welcome to the Nissan Patrol Forum

I am a technical retard with 5 thumbs on each hand ...;
so from that perspective I should not give any advice.

The error codes you can Google:

1089 Fuel Pump fault
0093 Fuel System Leak
0087 Fuel Rail System
0090 Fuel pressure Regulator
0088 High fuel pressure
0235 Turbo charge fuel sensor

Both repairs / replacements will be pricey.
I would think that the error codes point more towards the Diesel Pump. ??
And as far as I know one can have the dieselpump refurbished which might be cheaper than replacing it.

My suggestion would be ... get a third opinion at your next Bosch service center.
Good luck.

:salute:

Wilkie
Patrolman 1000+
Patrolman 1000+
Posts: 1465
Joined: 24 Feb 2014 15:33
Full Name: Errol Wilken
Nickname: Wilkie
Home Town: Pretoria
Current 4x4: 1999 4.5 GRX Nissan Patrol
2004 BMW 3.0D X5
Home Language: Afrikaans
Has thanked: 70 times
Been thanked: 90 times

Re: ZD30 not starting

Post by Wilkie » 20 Jun 2018 12:53

Check your fuel filter sensor . it might got water in and that will cut power to engine...

User avatar
Kagiso II
Patrolman 1000+
Patrolman 1000+
Posts: 3623
Joined: 10 Jun 2009 16:58
Full Name: Mac Mc Menamin
Nickname: Oom Mac [Uncle Mac] [Uncle] [Oompie] Kagiso
Home Town: BrentwoodPark, Benoni
Current 4x4: 1982 Datsun Safari 2,8 aka LOBO; [1,300,000 Km verby !]
'99 PATROL 4,2 diesel.
2012 Jimny [SWAMBO se Kantoor-toe]
Home Language: AFRIKAANS
Location: Benoni and wherever the Outreach takes me.
Has thanked: 269 times
Been thanked: 100 times
Contact:

Re: ZD30 not starting

Post by Kagiso II » 20 Jun 2018 14:27

Faulty battery - not giving enough AMPS .. [may be 12 Volt but the amps too low .. Had that TWICE with my Nissan Hard Body AND my 3,0 Patrol
Don't bring God down to your level of faith ... bring your faith up to His level!

juice
Senior Member
Senior Member
Posts: 161
Joined: 30 Jul 2010 16:40
Full Name: greg justus
Nickname: juice
Home Town: benoni
Current 4x4: patrol 2001
safari 1984 wagon
safari 1982 wagon
Home Language: english
Has thanked: 1 time
Been thanked: 10 times

Re: ZD30 not starting

Post by juice » 20 Jun 2018 18:49

NATS (Nissan anti theft system )
If your battery has been disconnected for a while the NATS wants to see both keys that have been programmed into to
the ecu , just put first key in turn car on / take the second key turn car on , it should reset
I had my pump done a few years back and had a similar problem , see if you can get a scan tool
and check the nats system , there is a code that usally comes up if I remember it was p504 , which is the control module
on top of the pump for the fly by wire controls to the gas that also can give hassels ,also check the plug that fits
in to the pump , also known to give some hassels and that will throw all the codes you are getting

give me call if you need anymore assistance
juice

sorry reread your post , you were driving when the problem occurred

User avatar
Michael
Moderator
Posts: 2561
Joined: 05 Mar 2014 14:39
Full Name: Michael
Nickname: Steyn
Home Town: Centurion
Current 4x4: Patrol GU 4.2 Turbo Diesel
Home Language: Afrikaans
Location: Centurion, PTA
Has thanked: 151 times
Been thanked: 246 times

Re: ZD30 not starting

Post by Michael » 21 Jun 2018 02:17

I think JoshJ had a similar problem with his CRD 3.0 when he still had it. The CRD has 2 fuel filters in the engine bay and the one (smaller one on the LH side) sometimes gets changed with the wrong filter which blockes very quickly and the result is fuel starvation.
On the CRD the fuel rail pressure must run 1,200bar and more, but if the filter is blocked the high pressure pump will not be able to produce the required pressure and might make sense why the error codes point to the fuel system parts.
Also might explain why the inline pump helped to get you home.

Having said that, this was on a CRD, not sure if yours is a DI?
"The Just shall live by Faith" Rom1:17

Check out my build here My Patrol
And my engine rebuild here mostly engine related stuff

velzing
Newbie
Newbie
Posts: 3
Joined: 20 Jun 2018 10:33
Full Name: Erik Velzing
Nickname: vellie
Home Town: Windhoek
Current 4x4: Nissan Patrol Y61
Home Language: Spanish
Been thanked: 4 times

Re: ZD30 not starting

Post by velzing » 29 Jun 2018 12:38

Thank you all for your answers and moral support.
The mechanic replaced the pressure relief valve, but there is still a fuel pressure problem.
Pressure goes up when it should go down and vice versa.

I really appreciate you support and I will keep you updated.

It has been 2 months nos since I last drove my dear Patrol...

User avatar
Kagiso II
Patrolman 1000+
Patrolman 1000+
Posts: 3623
Joined: 10 Jun 2009 16:58
Full Name: Mac Mc Menamin
Nickname: Oom Mac [Uncle Mac] [Uncle] [Oompie] Kagiso
Home Town: BrentwoodPark, Benoni
Current 4x4: 1982 Datsun Safari 2,8 aka LOBO; [1,300,000 Km verby !]
'99 PATROL 4,2 diesel.
2012 Jimny [SWAMBO se Kantoor-toe]
Home Language: AFRIKAANS
Location: Benoni and wherever the Outreach takes me.
Has thanked: 269 times
Been thanked: 100 times
Contact:

Re: ZD30 not starting

Post by Kagiso II » 29 Jun 2018 19:35

velzing wrote:
29 Jun 2018 12:38
Thank you all for your answers and moral support.
The mechanic replaced the pressure relief valve, but there is still a fuel pressure problem.
Pressure goes up when it should go down and vice versa.

I really appreciate you support and I will keep you updated.

It has been 2 months nos since I last drove my dear Patrol...
Eishhhh Bru, that sounds like an EARTH and / or polarity problem to me? PLEASE have the battery tested .. than go through the wiring harnass for an unwelcome short
Don't bring God down to your level of faith ... bring your faith up to His level!

velzing
Newbie
Newbie
Posts: 3
Joined: 20 Jun 2018 10:33
Full Name: Erik Velzing
Nickname: vellie
Home Town: Windhoek
Current 4x4: Nissan Patrol Y61
Home Language: Spanish
Been thanked: 4 times

Re: ZD30 not starting

Post by velzing » 03 Jul 2018 09:48

Thanks again all for your replies!
I have my car back.
It was the famous fuel pressure relief valve on the fuel rail.
But the first mechanic messed up something electrical on the fuel pump and made things worse.
The good thing: I know which mechanic to go to next time.

Best to all of you from Namibia!

Post Reply

Return to “09. Engines”

Who is online

Users browsing this forum: No registered users and 1 guest