Search found 6 matches

Return

by Florian320
03 Sep 2014 08:10
Jump to forum
Jump to topic

Re: My GU 4.2 Turbo Diesel

Wow, that seems to have been some serious work!

And it ended with a great result, congratulations! Enjoy your ride!
by Florian320
01 Feb 2014 09:40
Jump to forum
Jump to topic

3.0 or bad mpg?

Hello! I wanted to share how I got to which patrol. It is actually 'we' but to make typing easier I'lll only write 'I'. I drove a '97 Defender TDI quite often and decided, I don't want such a car for myself. It is basically loud, slow, uncomfortable (especially in the back row), unbearable on bad du...
by Florian320
08 Mar 2015 15:59
Jump to forum
Jump to topic

Re: Patrol scrap yard in Sharjah, UAE.

Hi Tinus! I also had an issue with one of these switches, the passenger's seat wouldn't go backwards all the time. I managed to repair it: the easy part is to get access to the switch, unscrew it from the plastic panel it is in and even open it. A bit more challenging then is to bend the metal of th...
by Florian320
05 Sep 2015 09:54
Jump to forum
Jump to topic

Re: Distributor cap, rotator and ignition leads - just repla

Yep, that will be interesting. I will follow up with that but it will take some time until I really will have some figures of tank fillings.
by Florian320
06 Jul 2016 17:20
Jump to forum
Jump to topic

Re: Source for brake components

@Wilkie: the grab in for the brakes in my opinion only applies to ceramic brakes, not the steel brakes, regardless of the manufacturer.
At least Brembo is not mentioning anything like that and I can confirm after using them now that the immediately work, regardless of their temperature.
by Florian320
15 Nov 2016 20:15
Jump to forum
Jump to topic

Re: Collant temp high with low revs, strange look of radiato

Sorry, I didn't have time to write before. Problem solved: it was a mixture between a technical issue and stupidity. Stupidity was me checking the coolant fluid level only in the expansion container when the temperature rose. Technically the cap of the cooler was not sealing correctly. So the pressu...